Home Forums .NET libraries Xceed Zip & Real-Time Zip for .NET ZipArchive.comment gives unexpected internal failure

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • User (Old forums)
    Post count: 23064
    #20317 |

    When I try to add a comment to a new zipfile I get this error: “{“An unexpected internal failure occurred in the FileSystem component, or one of its descendants. Type: Xceed.Zip.ZipArchive FullName: \”}”

    Dim _zip As New ZipArchive(New DiskFile(filename))

    _zip.DefaultCompressionMethod = Xceed.Compression.CompressionMethod.Deflated
    If Not password Is Nothing Then _zip.DefaultEncryptionPassword = password
    _zip.AllowSpanning = True

    ‘Copy the contents of the source folder to the zip file
         If Not comment Is Nothing Then _zip.Comment = comment
           _zip_source.MoveFilesTo(m_events, “”, _zip, True, True, “*”)
           If Not ZipProgressEvent Is Nothing Then RaiseEvent ZipProgress(Me, New ZipProgressEventArgs(100))

           Return True

       Catch ex As Exception
            LastException = ex
            _zip = Nothing
       End Try

    The error occurs when I call the _zip.Comment = comment, the _zip.Comment gives the error.
    When I look at the internal exception I can see that the Xceed.zip.dll internally throws a System.NullrefferenceException on the property.

    Source: Xceed.Zip
    Stacktrace: bij Xceed.Zip.ZipArchive.get_Comment()

    The code itself run’s without any trouble, so the zipfile is created, but because of the nullrefference the ‘comment’ isn’t added.

    What am I doing wrong? Or is this a bug in the Xceed.zip.dll?


    Some extra info:
    VS2005 (buildmode set to x86)
    Windows 7 64-bit
    Xceed component suite 2010v1 (latest downloaded from website)

    Imported from legacy forums. Posted by Michel (had 2520 views)

    Xceed Support
    Post count: 5658

    Hi Michel,


    Please try the following beta build. They should address your issue. Thank you for reporting it.


    specifically at:



    Please let us know how it goes.  

    Imported from legacy forums. Posted by Mohamed [Xceed] (had 452 views)

    User (Old forums)
    Post count: 23064

    Hi Mohamed,

    Since I had a short vacation I couln’t reply to you.
    I tried the 4.2.10220.0 beta build and it gave the same error.
    Then I saw that there was a new version of the Component suite (2010v3) that contained version 4.2.10226.10060 of the .dll but that version also gave me the same error.

    Any idea’s?

    Imported from legacy forums. Posted by Michel (had 1448 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.