Home Forums WinForms controls Other WinForms controls WinDatePicker Mask Error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • User (Old forums)
    Post count: 23064
    #18368 |

    I’m having a problem with WinDatePicker in my application: when I try to put a WinDatePicker in a Form I get an error: “A valid mask could not be created”.
    Here some other details of the exception:

    System.InvalidOperationException occurred
    Message=”A valid mask could not be created.”
    at Xceed.Editors.DateMaskInfo..ctor(DateTimeFormatInfo editFormatProvider, String editFormatSpecifier)
    at Xceed.Editors.WinDatePicker.Initialize(Boolean allowDropDown)
    at Xceed.Editors.WinDatePicker..ctor()

    I receive this error only when my PC’s Regional Settings are set in Hungarian. I tried Italian, English, Czech, Russian, Portuguese but I didn’t receive any error in those cases.

    Someone has an idea of how I can solve this?
    Thank you very much.


    Imported from legacy forums. Posted by Ludmilla (had 4414 views)

    Xceed Support
    Post count: 5658

    I tried reproducing the error and I was not able to.

    I changed my Regional Settings to Hungarian and I created a form on which I dropped a WinDatePicker. I did not get any error at design time. After, when a ran the application, all went well, I could see the Hungarian customized calendar (for example, I now know that “Január” is January).

    I ran that test using the <a href=”http://download3.xceedsoft.com/Packages/3.2.7570.10530/XceedComponents.exe”>latest version</a> of our product.

    Imported from legacy forums. Posted by CharlesB (had 290 views)

    User (Old forums)
    Post count: 23064

    Hi, first thanks you for your help.

    My dlls versions are:
    Xceed.Editors 2.0.6171.0
    Xceed.UI 1.1.6171.0

    Last Friday (11-30-2007) we tried (the same way you did) several times to use WinDatePicker on 3 different PCs: three using WinXp and one using Win2000; all of them having the same version of dlls I reported. On two of them, one Win2000 and two WinXp, we received the error and only on one all worked well. On that PC we made a simple application with a form and a windatapicker and we built it. Then we ran the exe file on all other PCs and on a system using Windows Embedded and we received also the error.

    Today (12-03-2007) we tried again and (surprise!) on all the PCs with WinXP it worked. Only the one with Windows Embedded and Win2000 still get the error. All of them have the same dlls. Note that we didn’t installed anything in this period.

    Should I install a fix or something for my version of Xceed dlls? I’m thinking the error is caused by some kind of problem with date format and the system but this behaviour is very strange.

    Thank you again,

    Imported from legacy forums. Posted by Ludmilla (had 362 views)

    User (Old forums)
    Post count: 23064


    One more thing that may help: this morning we tried again to run our little test application on all the PCs and now it doesn’t work again on all the PCs. It seems that it doesn’t work in the morning and works in the afternoon. Only on Win 2000 and Win Embedded it doesn’t work in both cases.
    I’ve also installed the latest service pack for my version (I believe it’s 2.2.6565) but nothing changed.

    Sorry to bother but we are using that control in a very large application that we need to translate in hungarian very soon.

    Again, thanks for you help.

    Imported from legacy forums. Posted by Ludmilla (had 389 views)

    User (Old forums)
    Post count: 23064

    Hi again.

    Today I found out that if I change the short date format of the hungarian regional settings
    yyyy. MM. dd.
    yyyy. MM. dd
    (removing the final dot) the error does not occur.
    I think that for us is the way to go because it seems impossible to make it work in any other way.
    I will check though for a better solution if possible.


    Imported from legacy forums. Posted by Ludmilla (had 5440 views)

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.