Home Forums WPF controls Xceed DataGrid for WPF DataGrid v2.0 requires full trust to run in XBAP?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • User (Old forums)
    Post count: 23064
    #26153 |

    I don’t remember this happening in earlier versions of the DataGrid, but I’m trying to use the control in an XBAP with an InsertionRow. If I add an insertion row to the grid in TableView (I have not tried it in any other view), I get the following security exception:

    Request for the permission of type ‘System.Security.Permissions.UIPermission, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089’ failed.

    If I change the XBAP to a full trust application, the exception is no longer thrown and evertyhing works as expected. Everything about the grid (that I’ve tried thus far) works without elevated permissions except for the InsertionRow which makes no sense to me.

    Is there a reason for this, am I doing something wrong?

    Imported from legacy forums. Posted by Kennie (had 2135 views)

    Odi [Xceed]
    Post count: 426

    Well, the insertion row in the Live Explorer XBAP demo works and that app doesn’t need full trust. I’m not solving your issue, but this might be an indication that you are doing something wrong.

    (Live Explorer XBAP: http://xceed.com/Grid_WPF_Demo.html)

    Imported from legacy forums. Posted by Odi [Xceed] (had 3147 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.