Home Forums ActiveX components Xceed FTP for ActiveX An error occurs when using SendFile function

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #42659 |

    If I try to connect via DOS, I can transfer the files, but when I try to do with the FTP object next message appears: “The FTP server did not accept a FTP command for an unexpected reason”.

    Does anybody know which could be the reason?

    Thanks,

    Julius

    Imported from legacy forums. Posted by Julius (had 4920 views)

    Xceed Support
    Member
    Post count: 5658

    Hi Julius,

    Make sure that you are using the latest version of the DLL (you can download it from the <a href=”http://www.xceedsoft.com/download/updates.htm”>Update Center</a>). If the issue still persists, you will need to contact technical support (support@xceedsoft.com).

    They will need access to the FTP server in order to reproduce the error therefore please make sure that you are able to provide it.

    Imported from legacy forums. Posted by Jenny [Xceed] (had 380 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi again,

    I’m using the latest dll version. Actually, I started to use the CommandLogFilename function and these was the lines generated:

    < 220 pmiportal1 FTP server (SunOS 5.8) ready.
    > USER xxxxx
    < 331 Password required for sybase.
    > PASS xxxx
    < 230 User sybase logged in.
    > PWD
    < 257 “/sybase” is current directory.
    > TYPE I
    < 200 Type set to I.
    > MKD EAServer
    < 550 EAServer: File exists.
    > MKD EAServer/Repository
    < 550 EAServer/Repository: File exists.
    > MKD EAServer/Repository/WebApplication
    < 550 EAServer/Repository/WebApplication: File exists.
    > MKD EAServer/Repository/WebApplication/Contenido
    < 550 EAServer/Repository/WebApplication/Contenido: File exists.
    > MKD EAServer/Repository/WebApplication/Contenido/xml
    < 550 EAServer/Repository/WebApplication/Contenido/xml: File exists.
    > MKD EAServer/Repository/WebApplication/Contenido/xml/Sistemas
    < 550 EAServer/Repository/WebApplication/Contenido/xml/Sistemas: File exists.
    > PASV
    < 530 Can’t open passive connection

    Imported from legacy forums. Posted by Julius (had 533 views)

    Xceed Support
    Member
    Post count: 5658

    Hi Julius,

    You are most likely getting this error because the FTP server does not accept passive connections. Setting the PassiveMode property to false should correct the issue.

    Imported from legacy forums. Posted by Jenny [Xceed] (had 5253 views)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.