Home Forums WinForms controls Xceed Grid for WinForms WinForm generation drops col.initialize method Reply To: WinForm generation drops col.initialize method

User (Old forums)
Member
Post count: 23064

Normally, the red diagonal slashes means there is a mix up in the persistence code of the form.

As for the designer itself, the problem is most likely due to the fact that the version the designer refers to differs from the one in the GAC.

I’m not sure how to help you further other than specifying how the upgrade normally works, and what are the options.

First, once the project is upgraded to VS2008, the project should work as is, BEFORE updating to the .NET 2.0 components.  In other words, .NET 1.1 components should work fine in VS2008.

Second, once you upgrade our components to the latest .NET 2.0 version, and the “Specific Version” property of all Xceed references are set to false, the project should compile and work as is (except for the license key), since our components are backward compatible.

Third, if you want to use the .NET 2.0 components only for new development, and keep using the .NET 1.1 components for existing project, then you need to install the latest Service Pack for .NET 1.1 components.  Once this is done, you need to manually install the dlls in the GAC, so the designer will keep working.  To do this, copy the following dlls to the C:\Windows\assembly\ folder :

Xceed.Grid.dll, Xceed.Grid.Design.dll, Xceed.Editors.dll, Xceed.Editors.Design.dll, Xceed.UI.dll, Xceed.Validation.dll, Xceed.Validation.Design.dll

Once this is done, open VS2008, add the .NET 1.1 components you just added to the GAC into the Toolbox (you will need to browse to the folder where you installed the .NET 1.1 components, because the “Choose items” dialog box will only show assemblies from .NET 2.0 and up), in a different tab preferably, so you can distinguish which are .NET 2.0 and which are .NET 1.1 controls.  Then open your old project, make sure the design form is closed, make sure the “Specific Version” of all Xceed references are set to “true” this time, and make sure they refer to the .NET 1.1. versions.  If this is not the case, delete them and add them again, form the path where you installed the .NET 1.1.  components (again, they will not appear in the “Add Reference” dialog box, because it only shows assemblies from .NET 2.0 and up, so you need to use the browse button).

Once this is done, rebuild the project, open the designer, and the .NET 1.1 grid designer should be displayed, and you should be able to edit the grid at design time.

I just personally tested the second and third options again, and it works fine.

In your case, I can only suggest that you uninstall everything, go back in your source code to the point before upgrading to the .NET 2.0 components, then try the third option (or start working with the .NET 2.0 components for all your projects).

 

Imported from legacy forums. Posted by André (had 244 views)