Home Forums WinForms controls Xceed Grid for WinForms xceed grid turns into a red X

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #16953 |

    We use xceed grid 2.5 in our application. It happens quite often on our clients’ computers (1GB memory) that the xceed grid turns into a red X after the application runs a while. Does anyone have any idea on what causes this? Is it because of insufficient memory due to memory leak? You help is very much appreciated.

    Imported from legacy forums. Posted by caroll (had 1978 views)

    User (Old forums)
    Member
    Post count: 23064

    It is difficult to tell if this could be due to a memory leak.  We have corrected a few issues that could have an impact since version 2.5.

    I see to options to help you resolve this.  First, you could use a memory profiler to discover if there are memory leaks, and if it is the case, have some kind of memory count when your application runs on a client machine, and analyze the memory consumption when the problem occurs.

    The other option is to upgrade to the latest version (3.8), and see if you still reproduce the issue with this version.  Note however that you may have to update your code to use updated features (some methods and properties have been marked as obsolete and replaced by new ones), to make sure the memory leaks have not followed in your application.

    Imported from legacy forums. Posted by André (had 2163 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.