Home Forums WPF controls Xceed DataGrid for WPF remove dottet rectangle when using keyboard navigation

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #24817 |

    Hi,

    i searched the forum for a way to remove the dottet rectangle when i navigate with the keyboard up and down but could not find a thread.

    The Datagrid Properties are set to the following values:

    <xcdg:DataGridControl x:Name=”myGrid” ReadOnly=”False” ItemScrollingBehavior=”Immediate” NavigationBehavior=”RowOnly” VerticalAlignment=”Stretch” HorizontalAlignment=”Stretch” Height=”Auto”>

    If i select a row by mouse i looks fine, if i move with the keyboard the dottet line is shown around the current row.

    Is the a way to remove this dottet line?

    Is the a solution?

    Thanks Martin

    Imported from legacy forums. Posted by Martin (had 508 views)

    Xceed Support
    Member
    Post count: 5658

    You can do so by setting “Null” on the FocusVisualStyle property of the DataCell/DataRow.

    Refer to http://doc.xceedsoft.com/products/XceedWpfDataGrid/Styles.html for details on how to style grid elements.

    Imported from legacy forums. Posted by Marcus [Xceed] (had 230 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi Marcus,

    thanks a lot for your reply, here’s my solution if anybody else needs one:

    row:
    <Style TargetType=”{x:Type xcdg:DataRow}”>
    <Setter Property=”FocusVisualStyle” Value=”{x:Null}” />
    </Style>

    cell:

    <Style TargetType=”{x:Type xcdg:DataCell}”>
    <Setter Property=”FocusVisualStyle” Value=”{x:Null}” />
    </Style>

    bye Martin

    Imported from legacy forums. Posted by Martin (had 3201 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.