Home Forums WinForms controls Xceed Grid for WinForms receiving license expired on new projects

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #17826 |

    Using Visual Studio 2010 and Grid .Net 3.9 we are receiving license expired message when attempting to create a new Windows Forms solution. However all of our previous created projects work just fine.

     Just created a new windows forms application. Dropped the Xceed Grid from the toolbox onto the form. Edited the code behind to reflect the sample below (Not our real key) and execute. But receive the trail license key for this product has expired message when the form is trying to be created during run time.

    Imports Xceed.Grid

    Public Class Form1

        Private Sub Form1_Load(sender As Object, e As System.EventArgs) Handles Me.Load

            Xceed.Grid.Licenser.LicenseKey = “XXXXXXXXXXX”

        End Sub

    End Class

    Imported from legacy forums. Posted by Emerson (had 32 views)

    User (Old forums)
    Member
    Post count: 23064

    Never mind. It has been so long since starting a new project that requires the grid. Application Startup is where it needs to go and not Form.Load.

    Thanks anyway. 

    Imported from legacy forums. Posted by Emerson (had 8 views)

    Fawzi [Xceed]
    Member
    Post count: 722

    Hi Emerson,

    Since you mentioned that this exception is being thrown only with new projects, could you verify that the Grid, or one of its methods, is not used before calling the licensing statement. If that is not the case, could you use the “Xceed Components Licenser” (which should be installed along with the Xceed package on your machine) to verify which key is being used on your machine’s registry to unlock the product. If you have a valid key in there, could you send me your license key to support@xceed.com so that I can verify it.

    Imported from legacy forums. Posted by Fawzi [Xceed] (had 22 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.