Home Forums WinForms controls Xceed Grid for WinForms problem running CustomizeReportStyleForm. any ideas?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #15190 |

    If I run code to bring up the CustomizeReportStyleForm, such as the following:

    CustomizeReportStyleForm stylesForm = new CustomizeReportStyleForm(STYLESFOLDER);

    I get this exception:

    ‘Could not find any resources appropriate for the specified culture or the neutral culture. Make sure “Xceed.Grid.Reporting.CustomizeReportStyleForm.resources” was correctly embedded or linked into assembly “Xceed.Grid.Reporting” at compile time, or that all the satellite assemblies required are loadable and fully signed.’

    I also get this problem when trying to bring this form up from the installed sample code. I installed the components normally, but am wondering if they didn’t install correctly – maybe it’s worth uninstalling and trying it again.

    Imported from legacy forums. Posted by matt (had 2173 views)

    User (Old forums)
    Member
    Post count: 23064

    I think I had the same problem .. In my case it was the namespace ..make sure you copy the resource files to you new folder and you may also need to change the InitializeComponent() method:
    System.Resources.ResourceManager resources =
    new System.Resources.ResourceManager(typeof (CustomizeReportStyleForm));

    Imported from legacy forums. Posted by lauro.costa (had 433 views)

    User (Old forums)
    Member
    Post count: 23064

    It seems it is a problem related to Vista. The resx files needed to be regenerated. This will be corrected in the next release of the product.

    Imported from legacy forums. Posted by André (had 3348 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.