Home Forums WinForms controls Xceed Chart for WinForms fill area limits for Area charts and Bar charts

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #19202 |

    Is there a way to limit the fill area for Area charts and Bar charts to the lower limit of the chart?

    If my lower range is positive 50, I don’t want the fill covering the area below the chart.

     

    tks

    Imported from legacy forums. Posted by James (had 2173 views)

    Xceed Support
    Member
    Post count: 5658

    Hi James, 

    If I have understood you correctly, you can achieve this by setting the “UseOrigin” property to false.  

    By doing that, the area will begin at the minimum area value instead of the specified origin value. 

    If this is not what you are looking for, can you give us more details on what you are trying to achieve? maybe an application or a screenshot that demonstrate your problem.  

    Imported from legacy forums. Posted by Michel [Xceed] (had 341 views)

    User (Old forums)
    Member
    Post count: 23064

    Almost there!

    I am setting the UseOrigin value and it eventually gets there.

    I collect live data at 10 times per second. I manually set the origin to the lower chart limit, but the fill area stays below the chart until all data less than my lower limit has cleared the queue. Then my origin appears to be the lower chart limit.

    It seems like if I manually set the origin, the fill area should start where I tell it to. Or am I not setting to correct property?

    How do I start the fill area at my lower chart limit regardless of any data point in the queue?

     

    tks.

    Imported from legacy forums. Posted by James (had 426 views)

    Xceed Support
    Member
    Post count: 5658

    Hi James, 

     

    Can you send us a sample application that reproduces the problem so that we investigate this in more detail?

    You can send it to support@xceed.com ,  please include a reference to this forum post in your email.  

    Imported from legacy forums. Posted by Michel [Xceed] (had 210 views)

    User (Old forums)
    Member
    Post count: 23064

    Found it…

    I need to leave the UseOrigin set to true. Just set the origin to the value of my lower chart limit.

    Now all my data below the chart gets the fill.

    I just need to “correct” all my data points in the queue so nothing is less than my lower limit.

     

    tks.

    Imported from legacy forums. Posted by James (had 465 views)

    User (Old forums)
    Member
    Post count: 23064

    Now I need to to something similar to a bar chart with multiple bars.

    I only want the fill effect to draw from the lowest data point to the highest data point, not all the way down to the chart lower limit.

    ??

    Imported from legacy forums. Posted by James (had 485 views)

    Xceed Support
    Member
    Post count: 5658

    Hi James, 

    It would be the same for the Bar chart.

    You only need to set UseOrigin to false for it to only draw the lowest to highest data points.

    You can see it in action by checking the chart sample application; Check the Standard 2D Bar sample under  All Examples / Chart Types / Bar in the treeview. uncheck “Use Origin”  

    Imported from legacy forums. Posted by Michel [Xceed] (had 214 views)

    Xceed Support
    Member
    Post count: 5658

    Hi James, 

    It would be the same for the Bar chart.

    You only need to set UseOrigin to false for it to only draw the lowest to highest data points.

    You can see it in action by checking the chart sample application; Check the Standard 2D Bar sample under  All Examples / Chart Types / Bar in the treeview. uncheck “Use Origin”  

    Imported from legacy forums. Posted by Michel [Xceed] (had 2531 views)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.