Home Forums .NET libraries Xceed SFTP/FTP for .NET errors 421, 426, command socket

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #20909 |

    Hi, I’m using Xceed FTP for .NET 3.5

    I’m writing an application to download files by FTP

    Some times It works but some times I get exceptions like these

    <color=”red”>

    Xceed.Ftp.FtpInvalidStateException: The command socket was disconnected from the FTP server.

    Xceed.Ftp.FtpReplyException: (reply code 421)

    Xceed.Ftp.FtpReplyException: Connection closed; transfer aborted. (reply code 426)

    Xceed.Ftp.FtpReplyException: Terminating connection. (reply code 421)

    </color>
    my code is somethig like this
    <color=”navy”>
    Dim clientXceed As New FtpClient
    clientXceed.Timeout = 900
    clientXceed.Connect(189.132.168.45)
    clientXceed.Login(“user”, “pass”)
    clientXceed.ReceiveFile(“song.mp3”, “c:\songs\song.mp3”)
    clientXceed.Disconnect()
    </color>

    The remote server is windows XP and IIS 5.1
    The client is windws XP net framework 3.0 and I’m programming in visual studio 2005

    how can I solve this problem?

    I’m able to modify settings in the server and client.

    Thanks!

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by GABRIEL (had 3365 views)

    Xceed Support
    Member
    Post count: 5658

    Could you set the TraceWriter property, so we can see the communication with the server?

    ftpClient.TraceWriter = New StreamWriter(“path of your log\log.txt”)

    What you are doing seems pretty standard. I tested your code snippet with our server and all seems fine. Would it be possible for us to get access to your server, so we can try to reproduce the issue? If so, you can send the connection information to <a href=”mailto:support@xceedsoft.com”>support</a>.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by CharlesB (had 3483 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.