Home Forums WPF controls Xceed DataGrid for WPF ArgumentNullException: Value cannot be null. Parameter name: property

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • hamd1
    Participant
    Post count: 4
    #43775 |

    I move the Xceed DLL from thier location and the Xaml designer handle
    this exception ArgumentNullException: Value cannot be null. Parameter name: property
    , the error apear in the first line of the xaml

    at System.Xaml.XamlObjectWriter.WriteStartMember(XamlMember property)
    at System.Xaml.XamlWriter.WriteNode(XamlReader reader)
    at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)
    at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter)
    at System.Windows.SystemResources.ResourceDictionaries.LoadDictionary(Assembly assembly, String assemblyName, String resourceName, Boolean isTraceEnabled)
    at System.Windows.SystemResources.ResourceDictionaries.LoadThemedDictionary(Boolean isTraceEnabled)
    at System.Windows.SystemResources.FindDictionaryResource(Object key, Type typeKey, ResourceKey resourceKey, Boolean isTraceEnabled, Boolean allowDeferredResourceReference, Boolean mustReturnDeferredResourceReference, Boolean& canCache)
    at System.Windows.SystemResources.FindResourceInternal(Object key, Boolean allowDeferredResourceReference, Boolean mustReturnDeferredResourceReference)
    at System.Windows.StyleHelper.GetThemeStyle(FrameworkElement fe, FrameworkContentElement fce)
    at System.Windows.FrameworkElement.UpdateThemeStyleProperty()
    at System.Windows.FrameworkElement.OnInitialized(EventArgs e)
    at System.Windows.FrameworkElement.TryFireInitialized()
    at System.Windows.FrameworkElement.EndInit()
    at System.Windows.Controls.ItemsControl.EndInit()
    at MS.Internal.Xaml.Runtime.ClrObjectRuntime.InitializationGuard(XamlType xamlType, Object obj, Boolean begin)

    Fawzi [Xceed]
    Member
    Post count: 722

    Hi,

    Could you give me more details regarding what do you mean by you moved the dlls from their location? Have you updated the references after moving the dlls? If yes, could you send me a simple stand alone sample project which reproduces the exception so that I could have a closer look.

    daniel.crowe
    Participant
    Post count: 1

    I’m having the same issue. Did you happen to find the solution?

    Webern
    Participant
    Post count: 1

    I am also having this problem.

    DocX document = DocX.Create(“./Test.docx”);
    document.ApplyTemplate(“./Template.dotx”);

    {System.NullReferenceException: Object reference not set to an instance of an object at System.IO.Packaging.PackagePart.GetStream () [0x00000] in /Users/builder/data/lanes/4992/mono-mac-sdk/external/bockbuild/builds/mono-x64/mcs/class/WindowsBase/System.IO.Pa…}

    BoucherS
    Participant
    Post count: 1

    Hi,

    Can you give more details on this ?
    I created a simple sample (based on yours) and everything compiles normally. Here’s my sample for a Console Application :

    static void Main( string[] args )
    {
    DocX document = DocX.Create(“Test.docx”);
    document.ApplyTemplate(“Template.dotx”);
    document.Save();
    }

    The file “Template.dotx” contains data.
    The file “Test.docx” will be created and filled with the file “Template.dotx”.
    The file “Test.docx” is the resulting file.

    I referenced the latest Xceed.Words.NET (v1.3) and it worked.
    I also try with referencing the OpenSource version Xceed.Words.NET (v1.1) and it worked.
    Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.