Home Forums WinForms controls Xceed Grid for WinForms Xceed unbound data grid performance

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #16032 |

    Hi,

    I have a concern regarding the performance of having grid with unbound data rows. I have created and loaded a grid with 29 columns and 10 rows (unbound data rows), but the performance seems to be poor. (Everything goes slower after I load the grid). I wonder about any possible ways to enhance its performance?

    In terms of performance, how does grid populated by bound data compared with that populated by unbound data?

    Is there any information regarding the performance of Xceed grid I can find?

    Thanks a lot,

    Sophia

     

    Imported from legacy forums. Posted by Sop (had 2079 views)

    Xceed Support
    Member
    Post count: 5658

    There is not really any documentation regarding the performance directly. There some UI Virtualization, but this only applies to the DataRows. There is no “column virtualization”.

     Did you run the grid in “Debug mode” only? If you run it in “Release mode” (using CTRL+F5), it should be faster. Using bound or unbound data should not change that much in regard of the performance of the grid.

    Imported from legacy forums. Posted by CharlesB (had 630 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi Charles,

    Thanks so much for your reply. I was running it in “Debug mode” (using F5). I just tried running it in “Release mode” and it seems to be a bit faster now.

     Would you suggest that the slower performance may be due to the higher number of columns (besides the fact that it was in Debug mode)?

    For the UI Virtualization Mode, currently my grid has this setting as “Cells”. Does it mean that the UI Virtualization is already activated?

    Thanks & Regards,

    Sophia

    Imported from legacy forums. Posted by Sop (had 1954 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.