Home Forums WinForms controls Xceed Grid for WinForms Xceed Grid can export a data source using relationships?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #15082 |

    I have tried to export the contents of a Xceed Grid using the export to excel functionality and the suggested code, but whe I have a grid with master and detaill it seems to raise and excpetion. The tables in the dataset (the actual datasource) are “related” by a relationship, and the data displays fine on the datagrid but it doesn´t export it to excel! is that a known issue?

    Imported from legacy forums. Posted by cursositca (had 3741 views)

    User (Old forums)
    Member
    Post count: 23064

    This is not a known issue, the export works fine when a detail grid with a relationship is present.

    Can you send a sample application that reproduce the issue to <a href=”mailto:support@xceedsoft.com”>support</a>, so we can investigate this further?

    Imported from legacy forums. Posted by André (had 265 views)

    User (Old forums)
    Member
    Post count: 23064

    OK! Seems I could finally export it! Now the problem is when I try to open the excel file, excel reports it cant open the file, the error is:

    “Problems came up in the following areas during load:

    Table

    This file cannot be opened beacuse of errors. Errors are listed in ….log file”

    Imported from legacy forums. Posted by cursositca (had 367 views)

    User (Old forums)
    Member
    Post count: 23064

    And what does the log file tell?

    Imported from legacy forums. Posted by André (had 363 views)

    User (Old forums)
    Member
    Post count: 23064

    This the error

    ERROR XML en Tabla
    RAZÓN: Valor incorrecto
    ARCHIVO: C:\export.xls
    GRUPO: Row
    ETIQUETA: Cell
    ATRIB: Index
    VALOR: 1

    Which in english would be:

    XML Error in Table
    Reason: Incorrect Value
    File: C:\export.xls
    Group: Row
    Label: Cell
    Attribute: index
    Value: 1

    Imported from legacy forums. Posted by cursositca (had 258 views)

    User (Old forums)
    Member
    Post count: 23064

    Can you send a project that reproduces the issue to <a href=”mailto:support@xceedsoft.com”>support</a> so we can investigate this further?

    Imported from legacy forums. Posted by André (had 5000 views)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.