Home Forums WinForms controls Xceed Grid for WinForms Xceed.Grid.Licenser.LicenseKey = "xxx" takes an AGE to complete

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #17693 |

    Hi, we use version 3.8.8577.11540 of the winforms grid control in our application, its referenced across 20 odd assemblies making up our solution.

    Setting the LicenseKey property of the Grid control is taking upwards of 20 seconds to complete on one clients site in particular but seems fine at other clients. I also set the same property on Xceed.Editors.License and this sets with absolutely no delay.

    The solution comprises several mixed vb and c# projects if that helps

    *Edit*

    I’ve just written a small console app with the same dependency and have timed how long it takes to set the license a bit more scientifically than just “AGES” 🙂

    System.Diagnostics.Stopwatch reports almost exactly 30 seconds every time this is called. Last 4 ellapsed milliseconds were 30,274 / 30,411 / 30,249 & 30,239 which looks almost like a 30 second timeout is being hit somewhere although it ultimately sets the license key ok

     

     

     Can anybody help?

     

    Cheers

    Martin 

    Imported from legacy forums. Posted by Martin (had 1689 views)

    Xceed Support
    Member
    Post count: 5658

    Hi Martin,

    Where and when are you setting the license keys? The license keys should be set in the main method or the entry point of your application. This command should not take this much time or it shouldn’t take any time to be set. There are no known issues with assigning the string to the LicenseKey property. Is this issue reproducible on a smaller scale application? Are you doing anything special when you are setting the license key?

    Imported from legacy forums. Posted by Marc [Xceed] (had 860 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.