Home Forums .NET libraries Xceed SFTP/FTP for .NET XCeed FTP ver 2.0 with .NET 3.5 App

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #21392 |

    Will version 2.0 of XCeed FTP work with a .NET 3.5 application?  We have an old .NET 1.1 application that utilizes the XCeed FTP 2.0 component, and I need to upgrade that application to a newer .NET Framework version that is supported under Windows 8.

     I’ve converted the app, and when I run the FTP-related portion of it, from the FileTransferStatus() subroutine there is generated the error message “Cross-thread operation not valid; Control ‘lblInProgress’ accessed from a thread other than the thread it was created on.”

     Thanks for any help anyone can provide.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by Kermit (had 631 views)

    Diane [Xceed]
    Moderator
    Post count: 1353

    Hi Kermit,

    Version 3.2 was the last version to support .NET 1.1, while version 3.3 was the first to support .NET 2.0 and up.

    Reference: http://xceed.com/FTP_NET_Whatsnew.html

    I would first suggest that you download a trial of the latest version (v4.4 in your case), to see if that resolves the issue.

    Link: http://xceed.com/FTN_Download.html

    If the issue is still present with the most recent version, then we will need a small stand-alone sample project that reproduces the issue in order to investigate further. Please send it by email at support@xceed.com and include a link to this forum thread for reference. Thank you.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by Diane [Xceed] (had 670 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.