Home Forums WPF controls Xceed DataGrid for WPF XBAP Deployment

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #23889 |

    I just tried to deploy my XBAP application on our company intranet and its says the Xceed WPF component must be installed in the GAC.

    How can I avoid this?

    I have setup the system so that our xbap app is signed and the cert is in the trusted publisher and trusted root, so their no permission issue, however when xceed grid is include client computer reports must be installed in gac.

    Imported from legacy forums. Posted by MattCheshire (had 541 views)

    User (Old forums)
    Member
    Post count: 23064

    We never experienced this when deploying our LiveExplorer XBAP. A few questions… When do you have this message? During the deployment or when you try to run the XBAP? How do you deploy? Do you use the Publish Now button of Visual Studio? Have you looked at the “Application Files” in the Publish section of your project’s properties? Is everything in order?

    One difference between our setup and yours is that our XBAP application references grid assemblies that are not in the GAC. I wonder if this error could be related to Copy Local. Have you tried setting the Copy Local to True for the grid’s assemblies?

    Imported from legacy forums. Posted by Michel (had 439 views)

    User (Old forums)
    Member
    Post count: 23064

    on your project properties, Publish tab, click the Application files and change teh Publish Status to teh xcedd controls to “Include”.

    Imported from legacy forums. Posted by dalia (had 3327 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.