Home Forums WPF controls Xceed DataGrid for WPF WPF and GCG

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #22923 |

    Hi,

    I have posted the same thread in Installation but I beleive this is the right place to post it.

    I have developed a small demo using WPF Grid. I have copied the files to a public server and it is working OK.

    I tried to run this application in another machine and I got the following error:

    Below is a summary of the errors, details of these errors are listed later in the log.
    * An exception occurred while determining platform requirements. Following failure messages were detected:
    + Unable to install or run the application. The application requires that assembly Xceed.Wpf.Controls Version 1.0.7170.16090 be installed in the Global Assembly Cache (GAC) first.

    XCeed is not really installed in this machine, but why does your demo works ok in the same machine.

    How does your demo application installs the assembly in the GAC ????

    Thanks in advance

    Imported from legacy forums. Posted by mvbaffa (had 1906 views)

    User (Old forums)
    Member
    Post count: 23064

    A few things you could check…

    1- Is the Xceed.Wpf.Controls.dll assembly in your project’s references?

    2- Have you checked the “publish” settings of your project? Go to the project properties / Publish / Application files. The Xceed.Wpf.Controls.dll should be included.

    3- Although I doubt it, this could be a problem of Copy Local. When we build our XBAP application, our assemblies are not in the GAC and, so, our references are Copy Local=True. If all fail you could try doing this.

    I don’t think we ever had these sort of problems to make it work. It was a pretty straightforward process.

    Imported from legacy forums. Posted by Michel (had 2989 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.