Home Forums WinForms controls Xceed Grid for WinForms Visual Studio – can’t select grid in VS UI

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #17728 |

    I have been upgrading to Visual Studio 2010. Now, my grids cannot be selected in the designer and grid icons now appear in the area below the form design. Any ideas?

    Imported from legacy forums. Posted by Clive (had 2373 views)

    Diane [Xceed]
    Moderator
    Post count: 1353

    Hi Clive,

    Could you provide us with a small stand-alone test project that reproduces the issue? You can attach it to a post in the forums (make sure to remove your license key), or send it by email to support@xceed.com with a link to this forum thread for reference. Thank you.

     

    Imported from legacy forums. Posted by Diane [Xceed] (had 169 views)

    User (Old forums)
    Member
    Post count: 23064

    I have reduced an example VS 2010 solution to pretty much just the UI and the problem still shows up (zip format – created by 7Zip).

     Regards,

     Clive

    Imported from legacy forums. Posted by Clive (had 220 views)

    Diane [Xceed]
    Moderator
    Post count: 1353

    Hi Clive,

    I think that the Grid Assistant always reappears when the version of the Grid changed after an upgrade. It appears inside the grid control, but the grid is docked top while the assistant is docked fill, and so the grid assistant appears to be under the grid. You can right click in the section occupied by the grid and select to hide the grid assistant.

    As for your other grid not showing up, there may have been an issue with your persistence during the update of your project. If we look in the code behind of the designer, in the InitializeComponent call, we see that grOrderLines is added to the collection of Controls, while grChildOrders is configured but not added to the Controls.

     

    Imported from legacy forums. Posted by Diane [Xceed] (had 224 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi Diane,

    I am seeing a different problem as I can’t even select the grid in the designer. In fact, if I add a new form to the project and then add a grid to that form, I get the grid icon displayed below the design area but the grid does not appear on the design surface. I wonder if the version of the grid I am using could be an issue? It is version 3.2.6403.0

    Regards,

     Clive

    Imported from legacy forums. Posted by Clive (had 157 views)

    Diane [Xceed]
    Moderator
    Post count: 1353

    Hi Clive,

    It is possible that the version you are using is causing issues. I am testing with version 3.8.12556 which is from 5-NOV-2012 (a newer version came out yesterday afternoon but I haven’t upgraded my machine yet).

    I tried adding a new form and added a grid on it, and this is what it looks like for me (see attached screen shot).

    If you want to upgrade to a newer version, please visit our Updates Center

    Imported from legacy forums. Posted by Diane [Xceed] (had 1541 views)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.