Home Forums WinForms controls Xceed Grid for WinForms Visual Studio 2010 Pro + Grid 3.9 (FW 4.0)

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #17459 |

    Windows 7 Pro x64, Visual Studio 2010 Pro x64, Grid 3.9 for framework 4

    1. Add Unbound column
    2. Add second unbound column
    3. Save project
    4. Set FieldName property – > Design Form Refresh -> All Colums dropped, only definition of column variable exists.

    Imported from legacy forums. Posted by Артем (had 6981 views)

    Xceed Support
    Member
    Post count: 5658

    Hi,

    Can you please send us a sample application that shows the erroneous behavior to support@xceed.com?

    Imported from legacy forums. Posted by Alain [Xceed] (had 375 views)

    User (Old forums)
    Member
    Post count: 23064

    screen capture video of problem: http://www.multiupload.com/XI48TQNKOK (MPEG4 file)

    test on VS2008 Pro x64 – OK, no problem (fw 3.5)

    Imported from legacy forums. Posted by Артем (had 227 views)

    Xceed Support
    Member
    Post count: 5658

    Hi,

    We could not download the file.

    Can you please send us a repro app that shows the problem you are facing along with a description of the problem?

    Imported from legacy forums. Posted by Alain [Xceed] (had 397 views)

    User (Old forums)
    Member
    Post count: 23064

    i send captured video at support@xceed.com

    Imported from legacy forums. Posted by Артем (had 292 views)

    User (Old forums)
    Member
    Post count: 23064

    Any answers???

    Imported from legacy forums. Posted by Артем (had 237 views)

    Xceed Support
    Member
    Post count: 5658

    Hi,

    I could not reproduce the issue at my machine.

    How are you refreshing the Design Time Form? I used the refresh button of the Solution Explorer window (check the attached image)

    Imported from legacy forums. Posted by Alain [Xceed] (had 162 views)

    User (Old forums)
    Member
    Post count: 23064

    After property change “FieldName” the form is reconstructed. It occurs in all versions GridControl.

    Tried to solve a problem itself…

    1. Has opened the old project (created in Visual Studio 2008) and at once has started on Run… (In FW 4.0) all works in Runtime.

    2. Has opened in a mode of the editor the form with GridControl all columns were gone. Thus announcements of columns remained.

    As the variant has sent a response in Microsoft.

    Probably it is problem Visual Studio…

    Tell please what version of Visual Studio you use for testing? At me 10.0.30319.1. GridControl 3.9.10308.13060, FW: v4.0.30319. Visual Basic / C#.

    Imported from legacy forums. Posted by Артем (had 428 views)

    Xceed Support
    Member
    Post count: 5658

    Hi,

    Here is the info about my setup:

    Microsoft Visual Studio 2010 – version 10.0.30319.1 RTMRel

    .NET Framework 4.0.30319

    Xceed Grid for .Net version 3.9.10308.13060

     

    Imported from legacy forums. Posted by Alain [Xceed] (had 191 views)

    User (Old forums)
    Member
    Post count: 23064

    At us identical systems… All identical (the only thing that system at me x64)
    It is possible to try to install VS 2010 in VMWare WS, for cleanliness of experiment. If there is a possibility make too…

    Imported from legacy forums. Posted by Артем (had 1036 views)

    User (Old forums)
    Member
    Post count: 23064

    I installed Windows 7 Ultimate x86 + Visual Studio 2010 Ultimate x86 (in VMWare WS 7.1). Has tested last version GridControl the same results – the code vanishes.

    All installations pure… 
    1. Installation Windows
    2. Installation VS2010 (full installation)
    3. Installation Xceed Grid 3.9
    4. Testing

    Imported from legacy forums. Posted by Артем (had 307 views)

    Xceed Support
    Member
    Post count: 5658

    Hi,

    I assigned your case to our lead Grid for .Net developer and he too could not reproduce the issue.
     
    Maybe it has something to do with how the GridControl is bound ?

    The only way to proceed from here is that you provide us with a sample project in which changing a column’s fieldname does what you are describing.

    Imported from legacy forums. Posted by Alain [Xceed] (had 409 views)

    User (Old forums)
    Member
    Post count: 23064

    Will not prompt that I should give to you? [*-)] The project with a remote code? And how you will understand with a problem? It is a problem it is necessary to consider in dynamics.

    1. To create the form
    2. To place GridControl
    3. To create UNBOUND columns (any)
    4. To save the project
    5. To close the designer of the form
    6. To open the designer of the form…

    Here we will not see in GridControl 3 columns created on step

    Well that is Trial versions, it is possible to check up a product and support in operation…

    Imported from legacy forums. Posted by Артем (had 940 views)

    Diane [Xceed]
    Moderator
    Post count: 1353

    Hi Артем,

    We tested several times the steps you explained, and shown in your video. I also tested on my own computer. However, we remain unable to reproduce the issue you describe. We are therefore unable to investigate further at this point.

    Unfortunately, this looks more like an odd glitch on your computer’s Visual Studio.

     

    Imported from legacy forums. Posted by Diane [Xceed] (had 673 views)

    User (Old forums)
    Member
    Post count: 23064

    INSTALL WINDOWS 7 AND VISUAL STUDIO 2010 PROF ON VIRTUAL PC OR VMWARE VM.

    I checked in Visual Studio 2010 x64 Ultimate / x86 Utimate / x64 Professional on the laptop and in the virtual machine everywhere this problem… 
    Has asked the colleague to test on the system… He has confirmed a problem…

    Imported from legacy forums. Posted by Артем (had 873 views)

Viewing 15 posts - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.