Home Forums WPF controls Xceed DataGrid for WPF Version 2.0 installation issue

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • Odi [Xceed]
    Spectator
    Post count: 426
    #26140 |

    Installation issue thread (removed from the “Version 2.0 Released” thread)

    Imported from legacy forums. Posted by Odi [Xceed] (had 7940 views)

    User (Old forums)
    Member
    Post count: 23064

    Okay, so I’ve downloaded the new version, uninstalled the old package as required, installed the new one, deleted the old references from my VC# 2008 project and gone to add the new ones, via Project/Add Reference as per the documentation…

    …but there’s now no sign of Xceed anything in the list of available references. Has there been a change in procedure or am I doing something wrong?

    Imported from legacy forums. Posted by Russell (had 573 views)

    User (Old forums)
    Member
    Post count: 23064

    Exactly the same thing occurs to me 😛

    Imported from legacy forums. Posted by Andrés (had 486 views)

    Xceed Support
    Member
    Post count: 5658

    I cannot recreate this issue. After installation if I click add reference and go in the .NET tab I see all version 2.0.X dlls.

    Which version of visual studio are you using?

    Normally, the package should create the registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders\Xceed DataGrid for WPF v2.0

    And should have a default value pointing to the binaries.
    i.e.: C:\Program Files\Xceed\Xceed DataGrid for WPF v2.0\Bin

    Can you run regedit and look if have this key installed?

    Imported from legacy forums. Posted by Vince [Xceed] (had 669 views)

    User (Old forums)
    Member
    Post count: 23064

    Visual C# 2008, Version 9.0.21022.8 RTM, with .Net Framework Version 3.5
    Operating system is Windows XP Home, SP 2.

    Checked with regedit just now and no, the key isn’t there. Specifically, drilled down as far as AssemblyFolders, but no Xceed anything in it.

    Imported from legacy forums. Posted by Russell (had 519 views)

    User (Old forums)
    Member
    Post count: 23064

    I have not this registry key. I have Visual C# 2008 Express Edition.

    I have also tried to re-register the dlls with gacutil, with no effect.

    Imported from legacy forums. Posted by Andrés (had 563 views)

    User (Old forums)
    Member
    Post count: 23064

    I’ve just tried to completely uninstall Xceed DataGrid 2.0 and reinstall it, but the problem persists. I can’t find nor the reference nor the registry key.

    Imported from legacy forums. Posted by Andrés (had 670 views)

    Xceed Support
    Member
    Post count: 5658

    It seems the installer could not find Visual Studio executable during installation.

    As a temporary work around you can:
    1) Add the key manually the key with a default value pointing to the path of your binaries:

    KEY :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders\Xceed DataGrid for WPF v2.0

    Value :
    (Default) = C:\Program Files\Xceed\Xceed DataGrid for WPF v2.0\Bin
    (or your installation path pointing to the binaries).

    2) Stop all instances of Visual Studio and run “devenv.exe /setup” as administrator.

    We based the installer on the EnvironmentPath key that should be stored in the location:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VS\EnvironmentPath
    ( http://msdn2.microsoft.com/en-us/library/bb166419.aspx )

    This key should be set to environment path for Visual Studio. If it is not set on your machine, the integration could not be completed. Can you check if you have a key set to the proper “devenv.exe” path in the registry EnvironmentPath location?

    If some configurations do not have this value, we will implement a secondary failsafe mean to retreive the path during installation.

    Imported from legacy forums. Posted by Vince [Xceed] (had 649 views)

    User (Old forums)
    Member
    Post count: 23064

    That VS environment path doesn’t exist in my configuration. The following keys are the closest that exist:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\Microsoft Visual C# 2008 Express Edition – ENU
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\MSDN Library for Microsoft Visual Studio 2008 Express Editions
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\Watson

    Given that both of us who’ve reported the problem so far are using VS Express Edition, I’m going to guess that’s the problem, that Express Edition doesn’t set EnvironmentPath.

    Trying the workaround now…

    Imported from legacy forums. Posted by Russell (had 534 views)

    User (Old forums)
    Member
    Post count: 23064

    That works! No sign of devenv.exe, presumably Express Edition either doesn’t include it or includes it under a different name, but adding the registry key alone suffices, the references can now be seen and imported. Thanks!

    Imported from legacy forums. Posted by Russell (had 473 views)

    Xceed Support
    Member
    Post count: 5658

    I filed the issue to be resolved in our system.

    Imported from legacy forums. Posted by Vince [Xceed] (had 446 views)

    User (Old forums)
    Member
    Post count: 23064

    Ok, the workaround also worked for me. I have nothing to add to this.

    However, I now get some compilation errors. But I’ll put them in a new thread, to avoid mixing topics.

    Imported from legacy forums. Posted by Andrés (had 538 views)

    Xceed Support
    Member
    Post count: 5658

    Just a quick note to let you know this will be fixed in next release.

    Imported from legacy forums. Posted by Vince [Xceed] (had 8691 views)

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.