Home Forums ActiveX components Xceed Encryption for ActiveX The Decrypt method of IXceedEncryptionPtr dose not decrypt t

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #42881 |

    Hello,

    The Decrypt method of IXceedEncryptionPtr dose not decrypt the data encrypted by the Encrypt method.

    infact the encrypt method dose not encrypt the whole data as a result the the decrypt function decrypts only the available data.
    Also the data that is decrypted is proper original data but some part of it is gone.

    i am using Two Fish Algo to encrypt, emoChainedBlocks mode, Haval Hashing Method and epmFIPS81 padding mode.

    The data is 255 characters long.
    with this settings i am not getting the original data, after decryption of encrypted data
    Also i am encrypting in a single pass.

    if i use the default settings of two fish algo every thing works fine.
    what may be the reason behind this working.

    regards,
    vishal

    Imported from legacy forums. Posted by smartvish (had 3574 views)

    Odi [Xceed]
    Spectator
    Post count: 426

    Hi Vishal,

    This definitely sounds like a good issue to send directly to technical support.

    However, I have a hunch that if you pad your 255-character string to 256 characters, so that it is a multiple of 32 bytes, it will work. But it has been a while since I worked with this library so better email support.

    Odi

    Imported from legacy forums. Posted by Odi [Xceed] (had 3622 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.