Home Forums WinForms controls Xceed Grid for WinForms Smart Client safe?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #13021 |

    I’m using the grid in a SmartClient app and it appears that at the point where the xceed.grid.dll is loaded I get hit by:

    ‘webserver’: Loaded ‘c:\windows\assembly\gac\xceed.grid\2.0.102.0__ba83ff368b7563c6\xceed.grid.dll’, No symbols loaded.
    An unhandled exception of type ‘System.Security.SecurityException’ occurred in IEExec.exe

    Am I not going to be able to use this in Smart Clients?

    Imported from legacy forums. Posted by Dustin_00 (had 2435 views)

    User (Old forums)
    Member
    Post count: 23064

    Can someone from Xceed answer this, please?

    Imported from legacy forums. Posted by rlaneve (had 360 views)

    Xceed Support
    Member
    Post count: 5658

    Hi guys,

    All of our controls require FullTrust to be displayed. Setting FullTrust should fix this issue.

    – Open the .NET Framework Configuration tool from the “Administrative Tools” control panel item.

    – Expand “Runtime Security Policy”

    – Expand “Machine”

    – Expand “Code Groups”

    – Expand “All Code”

    – Right-click “All Code”, select “New”

    – Select “Create a new code group” and give it a name

    – Select “URL” in the condition type combobox

    – Specify the URL of the intranet application with an asterix to indicate we want to trust all assemblies in that URL (e.g.”http://myserver/myfolder/*”)

    – Select “Use existing permission set”, and select “FullTrust” from the combobox

    – Click “Finish”

    I hope this helps!

    Imported from legacy forums. Posted by Jenny [Xceed] (had 3453 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.