Home Forums WinForms controls Xceed Grid for WinForms Possible Checkbox bug / why ?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #14331 |

    Hi

    I had a problem with a unbound column that was of type System.Boolean so I created a simple unbound table with a couple of columns with the first being System.Boolean and all the other the default. Next I add some data rows (say about 100) , some random data to the cells and set all the System.Boolean cells to false. None of my checboxes are thus checked.

    PROBLEM:

    If I try to check the checkbox but move the mouse up/down very quickly over other checkboxes I find that another checkbox sometimes gets checked. It’s as if ex. the checkbox only gets checked on a mouseup event (I don’t think this is the case however). It’s more difficult to recreate the error on my small test table – it seems as if my app, that’s quite CPU intensive at times makes it easier to re-create the error. I’m not keen to reverse engineer though. (i’m thus assuming that keeping the processor busy will make re-creating the error easier)

    WHY:

    This is a problem when you try to select multiple rows very quickly

    I’m not doing any funny overriding on my test app and can re-create the problem even though it’s a bit tricky. I’m using XCeedGrid 3 with latest upgrades

    Chow
    Greg

    Imported from legacy forums. Posted by g.kroger (had 2193 views)

    User (Old forums)
    Member
    Post count: 23064

    There is currently no issues related with the checkbox. Make sure you obtain the latest version of our control here : http://www.xceedsoft.com/download/updates.aspx

    Imported from legacy forums. Posted by Matt (had 2620 views)

    User (Old forums)
    Member
    Post count: 23064

    Is that somehow connected to my thread http://xceed.com/CS/forums/24263/ShowThread.aspx  ?

    Imported from legacy forums. Posted by Pawel (had 962 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.