Home Forums WPF controls Xceed DataGrid for WPF Licensing problem

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #25554 |

    Hi, I’m experiencing problems licensing the DataGrid. I’ve put the licensekey into the startup-method of the application and even added it once more in the Loaded-Method (which is definitely called), but it won’t work. Since there are multiple projects, I have also included the license-string in them, but it seems that setting the
    Xceed.Wpf.DataGrid.Licenser.LicenseKey = “DGxy-…”;
    -Property has no effect at all!
    Please help me!
    thanks in advance!

    Imported from legacy forums. Posted by Marc (had 4835 views)

    Xceed Support
    Member
    Post count: 5658

    What is not working? We will need more information in order to help.

    Imported from legacy forums. Posted by Jenny [Xceed] (had 239 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi, the licensing key must be set before any part of the Xceed code is executed. Hence it must be before the InitializeComponent() call of the window that contains your grid.

    I normally set as one of the first items in the application so as to avoid any problems.

    Imported from legacy forums. Posted by Derek (had 345 views)

    User (Old forums)
    Member
    Post count: 23064

    hi, I know that I have to set the license key before any code is executed (and of course I did so), but I still get an exception, saying that I should set the license-key, as if I did not set the key at all! I really do not understand this! please help me!

    Imported from legacy forums. Posted by Marc (had 422 views)

    User (Old forums)
    Member
    Post count: 23064

    As Jenny said you need to post the code black that around the area that you set the Licence key and also the exception dump. Then we might be able to help.

    Imported from legacy forums. Posted by Derek (had 427 views)

    User (Old forums)
    Member
    Post count: 23064

    hi again!

    Here is the code of my Application. As I said, there are more components (dlls) in my solution and the LicenseKey is set in the EXE-Component as well as in the dll, where the grid is called.

    Code in App.xaml:

    <Application x:Class=”MyApp.Client.App”
    xmlns=”http://schemas.microsoft.com/winfx/2006/xaml/presentation&#8221;
    xmlns:x=”http://schemas.microsoft.com/winfx/2006/xaml&#8221;
    Startup=”startup”>
    </Application>

    Code in App.xaml.cs:

    private void startup(object sender, StartupEventArgs e)
    {
    Xceed.Wpf.Controls.Licenser.LicenseKey = “DGxxx-xxxxx-xxxxx-xxxx”;
    this.main = new ClientMain();
    this.main.Show();
    }

    Code in dll-component:

    public partial class MyClass
    {
    public static MyClass()
    {
    Xceed.Wpf.Controls.Licenser.LicenseKey = “DGxxx-xxxxx-xxxxx-xxxx”;
    }

    public MyClass()
    {
    Xceed.Wpf.Controls.Licenser.LicenseKey = “DGxxx-xxxxx-xxxxx-xxxx”;
    InitializeComponent();
    }
    }

    any help appreciated! thanks in advance

    Imported from legacy forums. Posted by Marc (had 581 views)

    Xceed Support
    Member
    Post count: 5658

    Try setting the licence on the “Xceed.Wpf.DataGrid.Licenser.LicenseKey” instead.

    You will have to “unlock” each assembly for them to work… This have been designed that way to allow assemblies to be shared between products and to allow a greater flexibility in the redistribution of assemblies.

    At the moment, there are no “locked” features in the Xceed.Wpf.Controls assembly, therefore, you can omit setting the license key for it… as long as you unlock the “Xceed.Wpf.DataGrid.Licenser.LicenseKey”.

    Imported from legacy forums. Posted by Marcus [Xceed] (had 403 views)

    User (Old forums)
    Member
    Post count: 23064

    WOW!!! IT WORKS!

    thank you so much!

    Imported from legacy forums. Posted by Marc (had 6027 views)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.