Home Forums WPF controls Xceed DataGrid for WPF Licenser.LicenseKey Property

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #24381 |

    When I set my LicenseKey property in my Window_Loaded event, then when I run my application it won’t run. I am currently using a DGF key. Why?

    Also, when I deploy an application to another computer, the application doesn’t run, but when I return the progam back to my computer it runs?, now if I remove the DataGrid from my app and comment all the calls to the settings and what not, the application will run on another computer. Why is this happening? What am I doing wrong?

    Imported from legacy forums. Posted by Jason (had 1256 views)

    User (Old forums)
    Member
    Post count: 23064

    Try to set Licence key before Window_Loaded, in App Main. You can see in examples where it is. Ex:
    OnStartup(StartupEventArgs e)
    {
    Xceed.Wpf.DataGrid.Licenser.LicenseKey = “DGF…”.
    }
    Good Luck! Lena

    Imported from legacy forums. Posted by Lena (had 583 views)

    User (Old forums)
    Member
    Post count: 23064

    I tried that, but still no success.? I even wrote a single call to set the license,

    ex..

    private/public void SetWPFGridLicense()
    {
    Xceed.Wpf.DataGrid.Licenser.LicenseKey = “DGF…”;
    }

    Then in either the startup or on window loaded I made this call.

    Any other way to do this?

    Imported from legacy forums. Posted by Jason (had 904 views)

    Xceed Support
    Member
    Post count: 5658

    When you say: “The application doesn’t run”, what are the symptons? Is there an exception?

    If there is, can you provide the excpetion’s message and stack trace?

    Imported from legacy forums. Posted by Marcus [Xceed] (had 448 views)

    User (Old forums)
    Member
    Post count: 23064

    I had a similar problem and found that I had to include it in my window constructor before InitializeComponent() is called.

    public MyWindow() {
    Xceed.Wpf.DataGrid.Licenser.LicenseKey = “DGF**************”;
    InitializeComponent();
    }

    Trev

    Imported from legacy forums. Posted by Trevor (had 680 views)

    User (Old forums)
    Member
    Post count: 23064

    1st. Symptom: I added the key to the Licenser Component. that went fine!, But when I put the DGF key (the one Xceed sent to me) into the application, I get the exception/problem that reads something like: “Please make sure you are using a valid License Key and if so, please set the key in the OnLoaded Event or Startup Event etc…”

    2nd Symptom: If it does finally work, The program just won’t run, it throws up the Debug options dialog (1. Close Program, 2. Debug Program, 3. check for a windows solution on line).

    These are the symptoms I am having.

    Imported from legacy forums. Posted by Jason (had 543 views)

    User (Old forums)
    Member
    Post count: 23064

    Thanx Trev, I will try this one out and see if this works! *crossing fingers*

    Imported from legacy forums. Posted by Jason (had 654 views)

    User (Old forums)
    Member
    Post count: 23064

    I forgot to mention that this is the only place I set the key. My windows aren’t running in their own application. They exist in an assembly to be consumed by other applications so each window has the key.

    Imported from legacy forums. Posted by Trevor (had 588 views)

    Xceed Support
    Member
    Post count: 5658

    Can you send me your license key to belandj@xceedsoft.com? Also, is it possible you are using features (such as the statistical functions) that require a “vanguard” license?.

    Imported from legacy forums. Posted by Jenny [Xceed] (had 266 views)

    User (Old forums)
    Member
    Post count: 23064

    Jenny, I sent you the key in your email.

    All I am trying to use it for is just to display records contained in an XML file. I am writing an application that uses records stored in an XML Database (No SQL, ODBC, or Access databases are used, just plain XML).

    Also I am not using the Fixed Column feature as well. I am just using the basic DataGrid with the default style/theme (AeroNormalColorTheme) applied.

    I hope that this helps.

    Imported from legacy forums. Posted by Jason (had 723 views)

    Xceed Support
    Member
    Post count: 5658

    The key you have provided is invalid. I have sent you a valid key via email that should fix the issue 🙂

    Imported from legacy forums. Posted by Jenny [Xceed] (had 224 views)

    User (Old forums)
    Member
    Post count: 23064

    Thank You Jenny!

    I appreciate it very much! I will give the new key a try, and let you know what happens!

    Thank you very much again.

    Imported from legacy forums. Posted by Jason (had 8059 views)

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.