Home Forums .NET libraries Xceed Zip & Real-Time Zip for .NET LicenseException using v3.7 license with NET1.1 DLL (3.2.8115.0)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #19947 |

    Hi

    I have the latest version of the Xceed Suite, 3.7.

    But I have to compile with VisualStudio 2003 using NET Framework 1.1. So I downloaded and installed the latest service pack for NET 1.1:

    Xceed.Components.SP.NET1.1.8115.exe

    In VS2003 I’d set a reference the Xceed.Zip.dll in the service pack folder, it is version 3.2.8115.0

    Then I set the license key to:

    Xceed.Zip.Licenser.LicenseKey = “SFN37-?????-?????-????”     ‘ Also tested with “ZIN37-?????-?????-????”

    The line above throws the following exception:

    “System.ComponentModel.LicenseException: The license key used to license this Xceed product is invalid. Xceed.Zip.Licenser.LicenseKey must be set to a valid trial or registered license key before using this product. Please refer to the Licensing topic in the documentation for specific instructions on how to avoid this exception.”

    It worked before with a TRIAL license key. So I’m sure I’m setting the LicenseKey in the right place in the code.

    It is very URGENT!!

    Thanks in advance for your help!

    Imported from legacy forums. Posted by Luis (had 2057 views)

    Xceed Support
    Member
    Post count: 5658

    The problem here is that our license key are backward compatible, but not forward compatible. Since the version number is 3.2 (the compatible version with the 1.1 .NET Framework), you need a license key that starts with “ZIN32-…”. Contact our sales department, they will resolve the situation.

    Imported from legacy forums. Posted by CharlesB (had 302 views)

    User (Old forums)
    Member
    Post count: 23064

    Thanks for your help!!

    Kind regards

    Luis

    Imported from legacy forums. Posted by Luis (had 1327 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.