Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #13617 |

    Hello,

    I have a grid with an editable column. When the user hits return or enter in the column I want the next cell in the column to be selected and enter edit mode. e.g. just like in Excel.
    To do this I use the Cell KeyUp event.

    Normally, this works fine. However, as I display more forms on the screen, which all contain grids and are updated via ListChanged events from their datasource, the grid with the editable columns starts misbehaving.

    Sometimes when I press enter after clicking on a cell the KeyUp event does not fire and pressing enter again causes the system to make the ‘bong’ sound. The more other grids that are being updated the worse the form behaves until the grid hardly responds to keyboard input at all – not even new values being typed or the arrow keys being used.

    However, it always works for the first cell if you click on to place it into edit mode. Pressing return commits the value as usual but the KeyUp event does not fire. Pressing an arrow key rather than return changes the selected cell but only once. If I hold the arrow key down it sometimes responds eventually.

    Any thoughts?

    Many Thanks,

    David

    Any thoughts? It is almost as if the other grids updating is pulling focus away from

    Imported from legacy forums. Posted by David (had 3276 views)

    User (Old forums)
    Member
    Post count: 23064

    This has now been resolved by technical support.

    Imported from legacy forums. Posted by David (had 359 views)

    User (Old forums)
    Member
    Post count: 23064

    How did this get resolved and in what version? I’m getting a similar problem where I have GridComboBox cell editors in multiple columns on multiple grids. On dev machines it works fine, but when you hit a key to enter edit mode on the combo box, it repeatedly selects and drops/closed the combobox. This happen continuously until you close. If you click the cell to edit instead of hitting a key, everything is fine.

    We have the blueprint edition of Grid 2.2 and this does not occur, but the navigation is messed up when using arrow keys.

    Greg

    Imported from legacy forums. Posted by HHGClark (had 385 views)

    User (Old forums)
    Member
    Post count: 23064

    The version of the grid that fixed the bug for us was version 2.5.5228. We downloaded it from:

    http://www.xceedsoft.com/download/updates.aspx
    Package Version 1.1.5228.0 – May 2, 2005.

    The bug was caused by issues that occured when switching out of edit mode when the system was under high levels of CPU usage. The reason it worked fine on my dev machine was that the cpu usage was higher in production, so the effect was more severe.

    Hope this helps.

    David

    Imported from legacy forums. Posted by David (had 4011 views)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.