Home Forums WPF controls Xceed DataGrid for WPF Insertion Row in footers Gone in 1.1

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #23071 |

    DataTemplate template = new DataTemplate();
    template.VisualTree = new FrameworkElementFactory(typeof(CustomInsertionRow));

    TableView tv = new Xceed.Wpf.DataGrid.Views.TableView();
    tv.Footers.Add(template);

    grid.View = tv;

    Using this code
    the CustomInsertionRow is not visible

    but if I use the same code and add the insertionrow to the FixedFooters it works fine

    This started immediately after upgrading to v1.1
    Need some help?

    Imported from legacy forums. Posted by MiddleTommy (had 5001 views)

    User (Old forums)
    Member
    Post count: 23064

    You beat me to it! I was just about to post the same bug. InsertionRow works for Headers and FixedHeaders/Footers but not in Footers.

    Michael

    Imported from legacy forums. Posted by Michael (had 470 views)

    User (Old forums)
    Member
    Post count: 23064

    I cant find anything that will show in the Headers or Footers

    Imported from legacy forums. Posted by MiddleTommy (had 374 views)

    Xceed Support
    Member
    Post count: 5658

    Hi guys,

    Just wanted to let you know that this problem was identified and will be corrected. There is no workaround possible.

    This bug will be corrected in a Service Release ASAP.

    Imported from legacy forums. Posted by Marcus [Xceed] (had 251 views)

    Xceed Support
    Member
    Post count: 5658

    MiddleTommy, can you clarify your statement? Is the problem also seen with the Headers? or only the Footers? The bug I just identified only affects footers.

    Imported from legacy forums. Posted by Marcus [Xceed] (had 274 views)

    User (Old forums)
    Member
    Post count: 23064

    Yes The same code with

    tv.Headers.Add(template);

    does not show an insertionrow in the header of the grid.

    Imported from legacy forums. Posted by MiddleTommy (had 297 views)

    Xceed Support
    Member
    Post count: 5658

    Concerning the Headers problem… It is a second bug, not related to the first one concerning the Footers…

    There is a workaround that can be used until the service release is out to get Headers working from code behind and its as follows:

    TableView tv = new Xceed.Wpf.DataGrid.Views.TableView();

    //In the original posting, the template was added before setting the TableView on the
    // DataGridControl

    grid.View = tv;

    //If you move it after, it should work fine
    tv.Headers.Add(template);

    Imported from legacy forums. Posted by Marcus [Xceed] (had 350 views)

    User (Old forums)
    Member
    Post count: 23064

    This issue has been resolved, you can download the latest package here : <a href=”http://download3.xceedsoft.com/Packages/3.0.7273.12150/XceedComponents.exe”>http://download3.xceedsoft.com/Packages/3.0.7273.12150/XceedComponents.exe</a&gt;

    Imported from legacy forums. Posted by Matt (had 6030 views)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.