Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • User (Old forums)
    Post count: 23064
    #20340 |


    since the help file states “Xceed recommends that the PPMd compression method be selected when
    dealing with text files, XML files, and other files with high
    redundancy, as this is where the PPMd algorithm is able to create
    smaller files than the other compression methods.” I just tried it and just can’t do anything:

     System.Reflection.TargetInvocationException occurred
      Message=Xceed.Compression.PPMd.dll must be referenced as Copy Local in order to use PPMd CompressionMethod
           at Xceed.FileSystem.FileSystemItem.CopyTo(FileSystemEvents events, Object userData, AbstractFolder destinationFolder, Boolean replaceExistingFiles)
           at Xceed.FileSystem.FileSystemItem.CopyTo(AbstractFolder destinationFolder, Boolean replaceExistingFiles)
      InnerException: System.NullReferenceException
           Message=Object reference not set to an instance of an object.
                at Xceed.Compression.ManagedPPMdCompressor..ctor(Int32 maxOrder, Int32 subAllocatorSize, Int32 method, Assembly ppmdAssembly)

     There are all files in the output folder: Xceed.Compression.PPMd.v5.0.dll, Xceed.Compression.v5.0.dll, Xceed.FileSystem.v5.0.dll, Xceed.Zip.v5.0.dll.

     A quick look at  Xceed.Compression.PPMd.v5.0.dll using Reflector showed up it depends on Microsoft.VisualC — ??????? There is no mention inside the entire help “file” — just “use it, it is good”.

     Are you serious?!

    From an 2008 post here it also looks like it is x86 only … is this still the case???

    Imported from legacy forums. Posted by /\/\arkus (had 1770 views)

    Xceed Support
    Post count: 5658


    PPMd is still not supported by Xceed Zip for Compact Framework or 64-bit platforms.

    This is because unlike the rest of our .NET components, PPMd is written in managed C++, compiled with the 32-bit compiler.

    In your application properties, under the ‘Build’ tab, there is a ‘Platform target’ setting.

    The default value is ‘Any CPU’. On a 64-bit operating system, this makes your application run as a native 64-bit application. Loading the PPMd assembly fails in that setup because it’s 32-bit code.

    The same thing will happen if you set ‘Platform target’ to x64.

    If you set ‘Platform target’ to x86, your application will run as 32-bit and the PPMd assembly should load without problem.

    Imported from legacy forums. Posted by Alain [Xceed] (had 1286 views)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.