Home Forums WPF controls Xceed DataGrid for WPF Grid slow (cant figure out why)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #23458 |

    Hi all,

    First of all thank you for this beautiful componente 🙂

    I have one problem with it:

    The grid in my application is bound to a DataTable (with the use of your DataGridCollectionView).
    Now the problem is that if i navigate in the DataGrid, selecting a row is very slow (or: if i select a different row, there is a delay of about 0.5-1 seconds until it gets highlighted)

    Now, the strange thing is:

    If i write a small test-application, and use the same DataSet/DataTable and bind it to the DataGrid, everything works fast..

    Any ideas what the reason for this could be? 🙂

    Thank you for your help

    greets horgott

    Imported from legacy forums. Posted by horgott (had 2789 views)

    Xceed Support
    Member
    Post count: 5658

    It is possible that UI Virtualization is “off” for your application.

    You would need to post your XAML code for the Window/Page so you could check.

    Imported from legacy forums. Posted by Marcus [Xceed] (had 187 views)

    User (Old forums)
    Member
    Post count: 23064

    It is a bit difficult to post anything becuase its a huge page.
    Can i check on my own if this UI Virtualization is off?

    Imported from legacy forums. Posted by horgott (had 266 views)

    User (Old forums)
    Member
    Post count: 23064

    Marcus i just figured out that this delayed selection only affects rows with DBNull or null values .. is that possible?

    Imported from legacy forums. Posted by horgott (had 3905 views)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.