Home Forums WPF controls Xceed DataGrid for WPF Grid inside Grid: Dragging column headers crahes inner grid

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #26786 |

    Hi,

    I don’t know if this is a known problem, but searching the forum found nothing.

     

    I put an insertion row inside my fixed header and styled it.

    I use a ControlTemplate which has another DataGridControl inside. So, I’m using an inner grid to let the user

    select an entry which then becomes a new row in the outer grid.

     

    I can not drag a column header from the inner grid to the outer grid,

    but I can drag a column header from the outer grid to the inner grid.

    Dropping it, the inner grid crashes. No error message. The inner grid just goes blank.

    All columns and rows gone.

     

    Is this a known problem?

     

    CU,

    Michael.

    Imported from legacy forums. Posted by Michael (had 878 views)

    Xceed Support
    Member
    Post count: 5658

    This is not a known problem,

    I opened a bug report for this, somebody will investigate and report his/her findings back in this thread.

    Thank you for bringing this to our attention.

    Imported from legacy forums. Posted by Marcus [Xceed] (had 407 views)

    User (Old forums)
    Member
    Post count: 23064

    This is to let you know that the issue you submitted has been resolved, and the fix is now available through our “DataGrid for WPF Package 2.0.8277.15250” service release.  You can download it from the following page :

    http://xceed.com/pages/TopMenu/Downloads/Updates.aspx?Lang=EN-CA

    Imported from legacy forums. Posted by André (had 287 views)

    User (Old forums)
    Member
    Post count: 23064

    Thanks a lot,

     

    the error doesn’t occur any more.

    Good work!

     

    Michael.

     

    Imported from legacy forums. Posted by Michael (had 926 views)

    User (Old forums)
    Member
    Post count: 23064

    I tried using this template and I get an ObjectReferenceNotSet exception when I click on the expander. (I am basically using a Grid inside a grid)

    <DataTemplate x:Key=”CustomCellTemplate”>

    <Expander Header=”HInfo”>

    <StackPanel>

    <TextBlock Text=”inside info”/>

    <xcdg:DataGridControl AutoCreateColumns=”True”

    x:Name=”subDataGridControl1″

    ItemsSource=”{Binding}”>

    </xcdg:DataGridControl>

    </StackPanel>

    </Expander>

    </DataTemplate>

    but it works great if I switch the grid for this: <ListView ItemsSource=”{Binding}”></ListView>

    It has something to do with the Cell

       at Xceed.Wpf.DataGrid.Cell.ContentBinding_TargetUpdated(Object sender, DataTransferEventArgs e)

     

    Imported from legacy forums. Posted by Marco (had 537 views)

    Xceed Support
    Member
    Post count: 5658

    Hi, 

      this is a known issue that will be fixed in the next version of the DataGrid. 

    Imported from legacy forums. Posted by Chris [Xceed] (had 716 views)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.