Home Forums WinForms controls Xceed Grid for WinForms Grid V3.0 TextEditor MaxLength

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #14381 |

    I’ve noticed that TextEditor doesn’t have a MaxLength property, which it’s predecessor GridTextBox did. Is there an easy way to get this working in TextEditor without having to customise the control?

    At the moment I’m still using GridTextBox but as it’s obsolete it would be good to change it.

    Imported from legacy forums. Posted by Duncan (had 2818 views)

    Xceed Support
    Member
    Post count: 5658

    Hi,

    You need to use TextBox.TextBoxArea.MaxLenght instead.

    Imported from legacy forums. Posted by Vince [Xceed] (had 384 views)

    User (Old forums)
    Member
    Post count: 23064

    I tried that and it doesn’t seem to work. I also tested it just using a WinTextBox on a form and settng the max length of that in the same way via the property window. That had the same result. Perhaps this is now a question for the Editors forum?

    I can get around it using a normal TextBox with CellEditorManager so it’s no longer such a big problem.

    Imported from legacy forums. Posted by Duncan (had 601 views)

    User (Old forums)
    Member
    Post count: 23064

    This is indeed a bug that was fixed in the release of February 13, 2006 :

    “Fixed setting TextBoxArea.MaxLength doing nothing”

    If you are interested, you can obtain the fix here :

    http://download3.xceedsoft.com/Packages/2.0.6113.0/XceedComponents.exe

    Imported from legacy forums. Posted by Matt (had 3993 views)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.