Home Forums WinForms controls Xceed Grid for WinForms Grid Extensibility Sample Issue

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #15437 |

    Hi, Everything is ok in the extensibility sample but it only shows values in the first 7 filters. I have checked almost everything but so far not able to solve it. Is it some kind of limitation or bug ? Grid is showing all the datarows properly but the filter above column 8 and onwards are just empty. This is how I am defining columns:

    gridControl1.Columns[ “OrderID” ].VisibleIndex = 0;
    gridControl1.Columns[ “EmployeeID” ].VisibleIndex = 1;
    gridControl1.Columns[ “OrderDate” ].VisibleIndex = 2;
    gridControl1.Columns[ “ShipCountry” ].VisibleIndex = 3;
    gridControl1.Columns[ “Address1” ].VisibleIndex = 4;
    gridControl1.Columns[ “Address2” ].VisibleIndex = 5;
    gridControl1.Columns[ “Telephone” ].VisibleIndex = 6;
    gridControl1.Columns[ “Email” ].VisibleIndex = 7;
    gridControl1.Columns[ “Website” ].VisibleIndex = 8;
    gridControl1.Columns[ “Other” ].VisibleIndex = 9;

    The Grid is showing all the above columns and there are values as well but starting from column “Email” the filters are empty. IF I move the “Email Column above and change the index to 6 and “Telephone” column to 7, then the filter of “Email” column is ok but “Telephone” column’s filter is empty. Thanks for any suggestions/advice/ comments.

    Imported from legacy forums. Posted by mjt (had 2805 views)

    User (Old forums)
    Member
    Post count: 23064

    This is not a bug. This is only a sample application that is used to show how the grid can be setup. So there may be something in the sample that is not working properly, or you are missing something in the changes you made to the sample, but the grid can display as many filter rows as you require, that’s for sure.

    Imported from legacy forums. Posted by André (had 234 views)

    User (Old forums)
    Member
    Post count: 23064

    I have checked it again. The problem is not in the code. It has to do with “UIVirtualizationMode” . When I set it to “None” , there are always few incomplete filter lists and If I set it to “Cells” , the program crashes when ever the value of a filter is changed few times. So I guess there are issues with the grid if too many filters are added.
    Any suggestions?

    Imported from legacy forums. Posted by mjt (had 261 views)

    User (Old forums)
    Member
    Post count: 23064

    Can you send the sample to <a href=”mailto:support@xceedsoft.com”>support</a>, with the modification you have made to it, so we can investigate this further?

    Imported from legacy forums. Posted by André (had 3880 views)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.