Home Forums .NET libraries Xceed SFTP/FTP for .NET FTPS that is FTP using SSL not working

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #20903 |

    Can’t get the Xceed.Ftp.dll component to do TLS, SSL, or implicit-SSL. Tried upgrading to version 3.2.6563.0 of the DLL using package 2.2.6565.0, same exact problem. I’m using Titan FTP as the server. I’ve also tried placing the code in a separate DLL so that multiple applications around the company can use the same interface. See the code below, mobjFTP is a FTPClient class object, I’ve tried also using the AsyncFTPClient class as well, with the exact same result. It basically hangs when the Authenticate function is called, unless you use implicit-SSL, in which case it times out when attempting to send the file.

    If Not mSec = ggFtpPrc_SECURITY.IMP_SSL Then
    mobjFTP.Connect(pstrSite)
    Else
    mobjFTP.Connect(pstrSite, mcintDefImpSslPort, _
    Xceed.Ftp.AuthenticationMethod.Ssl, _
    Xceed.Ftp.VerificationFlags.None, Nothing)
    End If

    If mSec = ggFtpPrc_SECURITY.TLS Then
    mobjFTP.Authenticate(Xceed.Ftp.AuthenticationMethod.Tls, _
    Xceed.Ftp.VerificationFlags.None, Nothing, _
    Xceed.Ftp.DataChannelProtection.Confidential)
    End If

    If mSec = ggFtpPrc_SECURITY.SSL Then
    mobjFTP.Authenticate(Xceed.Ftp.AuthenticationMethod.Ssl, _
    Xceed.Ftp.VerificationFlags.None, Nothing, _
    Xceed.Ftp.DataChannelProtection.Confidential)
    End If

    mobjFTP.Login(pstrUsername, pstrPassword)

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by Shahzad (had 5005 views)

    User (Old forums)
    Member
    Post count: 23064

    Do you handle the CertificateReceived event? Are you sure your server support TLS or SSL, and not SSH? What is the DataChannelProtection level set on the server?

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by André (had 362 views)

    User (Old forums)
    Member
    Post count: 23064

    I don’t think you have to handle the certificate recieved event, unless there’s something you want to check against the certificate. It should just receive it. But just to be sure I did add a handler for that and just checked to make sure the server certificate is not expired, and got the same problem.

    Yes, I’m sure the server only supports SSL and TLS, I set it up myself. Also, there is no DataChannelProtection level set on the server, you can set it to anything you wan using the Prot command. Xceed never gets to issueing this command though, it hangs before that.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by Shahzad (had 219 views)

    User (Old forums)
    Member
    Post count: 23064

    The certificate must be received and accepted. In the event handler, do you accept the certificate?

    e.g.:

    static void client_CertificateReceived( object sender, CertificateReceivedEventArgs e )
    {
    e.Action = VerificationAction.Accept;
    }

    Once you do this, if you still get the problem, Could you send a log of the communication with the server, by setting the TraceWriter property?

    FtpClient.TraceWriter = new StreamWriter( @”D:\ftp.log”, true );

    Could we also get access to your server so we can reproduce the issue here? If so, send the information to <a href=”mailto:support@xceedsoft.com”>support</a> along, with a reference to this post.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by André (had 341 views)

    User (Old forums)
    Member
    Post count: 23064

    Tried your acceptance code, same thing. Sent log to support, however, tested with another tool, and it failed, so may be the server or my machine.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by Shahzad (had 304 views)

    User (Old forums)
    Member
    Post count: 23064

    Looks like a server issue, I’ll deal with Titan now to fix it.

    Applies to Xceed FTP for .NET. Imported from legacy forums. Posted by Shahzad (had 5648 views)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.