Home Forums WPF controls Xceed DataGrid for WPF Deploying by using Publishing

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #27081 |

    I have been having problems publishing my project.  I then tried pusblishing a simple program with a button.  I did that and it worked on the test machine.   I then put a datagrid on it and then published it and then tried to run it with the test machine and it didn’t work.

     

    I then added this code to the app.xaml.cs file (thinking it might be a licensing issue):

     

    public partial class App : Application

    {

    protected override void OnStartup(StartupEventArgs e)

    {

    Xceed.Wpf.DataGrid.Licenser.LicenseKey = “My professional registered code”; //”DGXXX-XXXXX-XXXXX-XXXX”;

    base.OnStartup(e);

    }

    }

     

    I still get the same error….  “A error signature”

    EventType: clr20r3   P1 : wlfappication3.exe   P2: 1.0.0.0

    P3 481b37f4   P4 : xceed.wpf.datagrid    P5 : 2.0.8164.15430

    P6 : 47 dad6ad   P7 : f7c    P8:8    P9 : system.componentmodel.license

     

    The dlls are in the directory with the .exe.  Also this is a shared drive that I am publishing to.  I also want to note again that the program works when I run it off that shared drive on the machine that I compiled it with….and it doesn’t work on the test machine.  (The test machine did work when the test program only had a button on the test program and no datagrid)

    Both machines are XP machines with the latest patches.

    Imported from legacy forums. Posted by Dave (had 806 views)

    Xceed Support
    Member
    Post count: 5658

    I don’t have enough details to reproduce, maybe you can send us a small project sample. Do you have the latest service packs on your machine?

     

    http://www.microsoft.com/technet/security/bulletin/MS06-040.mspx

     

    Imported from legacy forums. Posted by Vince [Xceed] (had 445 views)

    Xceed Support
    Member
    Post count: 5658

    Also can you tell us if you are running your application remotely (from a network location).

    Imported from legacy forums. Posted by Vince [Xceed] (had 380 views)

    User (Old forums)
    Member
    Post count: 23064

    That is the goal.  The app will be used by many people and the app will be needed to be updated frequently.  The goal is to have it on a mapped network drive so that it can be updated more easily and let everyone use the latest version.

    I’ll email the test app shortly.

     

    Imported from legacy forums. Posted by Dave (had 463 views)

    Xceed Support
    Member
    Post count: 5658

    We were not able to reproduce the error you are reporting; however, we did encounter other errors (without the grid and on another server) that lead us to believe that this is not supported.

    Have you considered using “click once” deployment? It may be a viable solution in your scenario.

    Imported from legacy forums. Posted by Vince [Xceed] (had 541 views)

    User (Old forums)
    Member
    Post count: 23064

    Hello,

     That was a “click once” deployment.

    If you go to the Microsoft help in Visual Studio 2008  (search for  “ClickOnce deployment”)

    You will get these instructions on how to do a click once app.

     

    To publish to a file share

    1. In Solution Explorer, select the application project.

    2. On the Build menu, click PublishProjectname.

      The Publish Wizard appears.

    3. In the Where do you want to publish the application? page, enter a valid file path using the format \\computername\applicationname, and then click Next.

      NoteNote:

      If users will install the application from the Web, this file path must correspond to the URL that the users will access. For example, if the users will install from http:\\www.microsoft.com\myapplication\publish.htm, you would enter the path c:\inetpub\wwwroot\myapplication.

    4. In the How will users install the application? page, select the location where users will go to install the application:

      • If users will install from a Web site, click From a Web site and enter a URL that corresponds to the file path entered in the previous step. Click Next. (This option is typically used when you specify an FTP address as the publishing location. Direct download from FTP is not supported. Therefore, you have to enter a URL here.)

      • If users will install the application directly from the file share, click From a UNC path or file share, and then click Next. (This is for publishing locations of the form c:\deploy\myapp or \\server\myapp.)

      • If users will install from removable media, click From a CD-ROM or DVD-ROM, and then click Next.

      NoteNote:

      This page does not appear if you enter a URL (HTTP address) in the Where do you want to publish the application? page.

    5. On the Will the application be available offline? page, click the appropriate option:

      • If you want to enable the application to be run when the user is disconnected from the network, click Yes, this application will be available online or offline. A shortcut on the Start menu will be created for the application.

      • If you want to run the application directly from the publish location, click No, this application is only available online. A shortcut on the Start menu will not be created.

      Click Next to continue.

    6. Click Finish to publish the application.

      Publishing status is displayed in the status notification area.

     

    I followed these instructions and I was getting the error that I was reporting to you guys.  (Following these instructions brings you to that publish page in VS2008)

     

    I also have been getting this error on my real project:

    Error signature

    EventType clr20r3   P1 : myapp2.exe   P2 : 2.0.0.0    P3:  481f0211

    P4 : presentationframework     P5 : 3.0.0.0     P6 : 470bc696     P7 : 660b

    P8 : e1     P9 : system.windows.markup.xamlparse

    Imported from legacy forums. Posted by Dave (had 1252 views)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.