Home Forums WinForms controls Xceed Grid for WinForms Checkboxes don’t appear in Vista

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #15414 |

    I’m using Grid verson 2.5.5123 running under the 2.0 framework. I just delivered the application to my client and we found that under Vista the checkboxes aren’t visible. My grid has 2 checkboxes, both are read-only, one is data bound, the other is manually added to the grid. One of them has cell click events set up so I can toggle the checked state in code.

    Copy the same exe to an XP system and the checkboxes are visible.

    Any idea why this happens? Are there any workarounds? This particular app doesn’t have to work in Vista but I have other apps that will surely need to.

    Imported from legacy forums. Posted by stevehiner (had 4863 views)

    User (Old forums)
    Member
    Post count: 23064

    Only our latest version of the grid is supported in Vista. For .NET 1.1, you need to use version 3.2, and for .NET 2.0 the version is 3.6.

    Imported from legacy forums. Posted by André (had 276 views)

    User (Old forums)
    Member
    Post count: 23064

    Ok, since I want Vista support in the grid I upgraded to the newest version of the ultimate suite.

    I installed the latest version of the suite then installed the service pack to get the latest version of the 1.1 fx compatible DLLs. I switched my licenses over to the new license keys in my code and updated the references to the 1.1 version of the libraries.

    When I run my project I get a license exception telling me that my license key isn’t valid for this version of the Grid. What did I do wrong? Is my version 3.6 license key not good for the version 3.2 DLL? Do I need a 3.2 specific license key?

    Thanks for the help.

    P.S. I also use the Zip, Compression and FileSystem DLLs in my project. Am I going to run into the same key versioning issues with them?

    Imported from legacy forums. Posted by stevehiner (had 334 views)

    User (Old forums)
    Member
    Post count: 23064

    Yes. .NET 1.1 components have different version number then .NET 2.0 components. In order to use 1.1 components, you need to use the corresponding key versions.

    .NET 1.1 components :

    Grid = 3.2
    Zip = 3.2

    .NET 2.0 components :

    Grid = 3.6
    Zip = 3.5

    Not that setting the ZIP licenser will unlock the other dlls on which it depends, so you don’t need to set the other licensers.

    Imported from legacy forums. Posted by André (had 254 views)

    User (Old forums)
    Member
    Post count: 23064

    Then why wasn’t I given a license key for the 1.1 fx components? I was only given a grid 3.6 license key with my subscription. Is there a way I can get license keys for the older components? I really don’t want to force my users to upgrade their framework if I can avoid it but I’d like to get the features added since my last subscription expired.

    Imported from legacy forums. Posted by stevehiner (had 512 views)

    User (Old forums)
    Member
    Post count: 23064

    Reading my last response I think I sounded more annoyed than I am. I’m really not annoyed at all. I just want to find out how to use the old libraries.

    Imported from legacy forums. Posted by stevehiner (had 339 views)

    User (Old forums)
    Member
    Post count: 23064

    No problem.

    You need to contact our <a href=”mailto:sales@xceedsoft.com”>sales</a> department to request keys for .NET 1.1 components. We can’t automatically generate the .NET 1.1 keys along the .NET 2.0 keys because of a technical issue. We apologize for the inconvenience this causes you.

    Imported from legacy forums. Posted by André (had 380 views)

    User (Old forums)
    Member
    Post count: 23064

    I contacted then and they sent me some keys for the 1.1 fx components. I suppose I should have started out trying that huh?

    Thanks for the help.

    Imported from legacy forums. Posted by stevehiner (had 6064 views)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.