Home Forums WinForms controls Xceed Grid for WinForms CellEditorManager

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #16504 |

    One of my Column in grid has custom CellEditorManager Created like this.

    DataGrid.Columns[ i ].CellEditorManager = new CellEditorManager(new TMComboAutoComplete(“”), true, true));

    TMComboAutoComplete is just control that inherits  Xceed.Editors.WinComboBox.

    This all works realy well Control is doing what it should and works just 100%.

     What is anoying is when I move between Columns.  CellEditorDisplayConditions is sett to CellIsCurrent. So if I am typing text in one column and move to the next I want to hit Tab then just start typing. This is the only column it wont work on. I always have to use the mouse to be able to start writeing.  Any Ideas what I need todo?

     

    best regards 

    Einar

     

     

    Imported from legacy forums. Posted by Einar (had 856 views)

    User (Old forums)
    Member
    Post count: 23064

    Do you get the same behavior if you use a regular WinTextBox?

    i.e. :

    DataGrid.Columns[ i ].CellEditorManager = new CellEditorManager(new WinComboBox(“”), true, true));

    If not, can you paste the code of the TMComboAutoComplete class here, along with the code showing how you set the editor in the grid (properties and events)?

    Imported from legacy forums. Posted by André (had 252 views)

    User (Old forums)
    Member
    Post count: 23064

    Yeep I do get same behavior.

    Only event I use there is Validation event. Tried to disable that but still same thing. [*-)]

     

    regards

    Einar

    Imported from legacy forums. Posted by Einar (had 293 views)

    User (Old forums)
    Member
    Post count: 23064

    I been looking more into this. It seams that if I hit Tab in the cell next to the troubled one. The cell editor dont gets the focus.

     

    SettingControlValue,  ActivatingControl dont fire upp until I press the cell with the mouse. Even tough it shows the control. (Drop down button is shown)

     I been commenting out code to try to figure this one out but no luck still….. [N]

    Imported from legacy forums. Posted by Einar (had 640 views)

    User (Old forums)
    Member
    Post count: 23064

    I did find way to fix this.

    in KeyDown event for the grid I did. 

                if (e.KeyCode == Keys.Tab)
                {
                    if (!this.ReadOnly)
                    {

                        this.MoveCurrentColumn(HorizontalDirection.Right);

                        CurrentCell.BringIntoView();

                        var data = CurrentRow as Xceed.Grid.DataRow;
                        if (data != null && data.IsBeingEdited)
                            CurrentCell.EnterEdit();
                       
                       
                        e.SuppressKeyPress = true;
                    }
                }

     

    Works so I am happy for now even tough this is odd bug.

    Imported from legacy forums. Posted by Einar (had 1240 views)

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.