Home Forums WPF controls Xceed DataGrid for WPF CellEditor Bug

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #23700 |

    I am using my own Template for the CellEditor. Trying to apply it to the CellEditor Template leads me to following Error when building the application:

    … Items.Count:0′ is not a valid value for property ‘CellEditor’.

    The control works fine in other scenarios. What should i change on the control in order to get this thing working?

    Imported from legacy forums. Posted by Ralf (had 569 views)

    Xceed Support
    Member
    Post count: 5658

    Can you post the code for the CellEditor and the DataGridControl’s Initialization?

    Imported from legacy forums. Posted by Marcus [Xceed] (had 188 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi Marcus,

    I think I have found the problem why it didn’t work. My custom control inherits from ComboBox which is not a DependencyObject. That’s why the Dependency Properties did not work properly. Had to find a workaround for this, because not inheriting from ComboBox would mean even more work.

    Sorry for accusing your grid to be buggy, I will never do it again 🙂

    cheers
    Silas

    Imported from legacy forums. Posted by Ralf (had 272 views)

    User (Old forums)
    Member
    Post count: 23064

    btw: i just noticed that my first post was cut of. I did write much more there.

    Imported from legacy forums. Posted by Ralf (had 3847 views)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.