Home Forums WinForms controls Xceed Grid for WinForms BufferedGraphicsContext cannot be disposed of because a buffer operation is currently in progress.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #16783 |

    Hi.

    After filling grid with new rows or new data like (textboxs,checkboxs comboboxs etc.) hcount of GDI objects growth up,

    and after method GridControl.Clear() or other operations, it not release or dispose this objects, and then the number of GDI objects is more 10000,

    thrown this exception.

    tnx 2 all

    Imported from legacy forums. Posted by Yu (had 4674 views)

    User (Old forums)
    Member
    Post count: 23064

    Can you provide a sample code snippet we could use to try to reproduce this issue on our side?

    Imported from legacy forums. Posted by André (had 524 views)

    User (Old forums)
    Member
    Post count: 23064

    Try on Xceed examples Master/Detail (Synchronized/Unsynchronized/tree view) if change betwen them in combo box, GDI objects will growth up, and u will see this error, or try in “Xceed Grid Live Explorer ” choose another examples

    tnx u

    Imported from legacy forums. Posted by Yu (had 676 views)

    User (Old forums)
    Member
    Post count: 23064

    We have reproduced the issue, but we can’t identify the source of the problem at this point.  We will investigate this further, and let you know when we find a solution to the problem.  Unfortunately, there is no workaround.

    Imported from legacy forums. Posted by André (had 3085 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi, you work at this problem, have you any solutions?

    Thanks!

     

    Imported from legacy forums. Posted by Yu (had 476 views)

    User (Old forums)
    Member
    Post count: 23064

    The problem is not fixed yet, and we have no time frame to offer at this point.

    Imported from legacy forums. Posted by André (had 3267 views)

    User (Old forums)
    Member
    Post count: 23064

    Has this problem been addressed in the latest version?

    Imported from legacy forums. Posted by fst (had 1554 views)

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.