Home Forums WPF controls Xceed DataGrid for WPF Binding to properties on DataGridCollectionViewSource

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #26292 |

    Hi,

    I have noticed that binding to properties on DataGridCollectionViewSource, namely AutoFilterMode and DistinctValuesConstraints doesn’t seem to support two way binding.

    The binding retrieves the current setting from the ViewSource ok, but even though I get no binding errors, changing the source of the binding the grid does not update.

    <xcdg:DataGridCollectionViewSource
    x:Key=”names”
    Source=”{Binding Source={StaticResource nameCardViewController}, Path=Data, Mode=TwoWay}”
    AutoFilterMode=”{Binding Path=DataContext.AutoFilterMode, RelativeSource={RelativeSource FindAncestor, AncestorType={x:Type Window}}}”>
    </xcdg:DataGridCollectionViewSource>

    The DataContext on the window is pointing to my controller object which has a depedency property call AutoFilterMode, which gets set before the window with the grid is shown. This all works fine until I add a mechanism to the UI to allow the user to choose another AutoFilterMode at runtime. The only way I can get the setting to apply is to create a new DataGridCollectionViewSource set its AutoFilterMode property and reapply that to the grid.

    Am I trying to do something not supported here?

    Imported from legacy forums. Posted by Ben (had 2424 views)

    Xceed Support
    Member
    Post count: 5658

    I entered a bug report for this. We will notify you of the availability of the fix on this thread.

    Imported from legacy forums. Posted by Chris [Xceed] (had 294 views)

    Xceed Support
    Member
    Post count: 5658

    This issue has been fixed and the latest package is available for <a href=”http://xceed.com/pages/TopMenu/Downloads/Updates.aspx”>download</a&gt;.

    Imported from legacy forums. Posted by CharlesB (had 3405 views)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.