Home Forums ActiveX components Xceed FTP for ActiveX 2147213300->The data transfer has been aborted by the FTP server

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #42784 |

    hello

    i have a program which is written with VB6

     i used xceed ftp to send a file from a file on pc to an as400 file

    it was working well..

    but now when some files are sending i get this error 2147213300->The data transfer has been aborted by the FTP server.
     (the file append as400 but i think i can’t get ‘sent’ message with xceed)  and then get this error..

    the files are similar, sent and not sent

    only different :

    sent files’ size: 8.750, 15.230, etc..

    error files’ size: 8.753, 18.539 ..etc 

    thirth digit is not zero. when i set the size of error file 8.750, 18.530, the file sent without problem.

    what can be the problem?

    why is that error?
     

    Imported from legacy forums. Posted by mermaiderya (had 8497 views)

    User (Old forums)
    Member
    Post count: 23064

    Do you mean that you modify the content of the file so the size of it ends exactly with 0?

    You say that it used to work.  What has changed between then and now?

    Imported from legacy forums. Posted by André (had 965 views)

    User (Old forums)
    Member
    Post count: 23064

    i only delete some blank part of the file..

    not delete data..

    only different is size, not the content of the file..i delete some space part of the file..

     

    Imported from legacy forums. Posted by mermaiderya (had 1132 views)

    User (Old forums)
    Member
    Post count: 23064

    Very strange problem.

    Again you said it was working before.  What has changed from then?  Did the ftp sever version changed?  The OS?  A new firewall?  Changes in the firewall settings? Something else? 

    Do you receive the error right away, or only after a certain period of time has passed?  If only after a certain period, try setting the KeepAliveInterval.

    Try from another client machine.

    You could try changing the PassiveMode property (true by default).

    Try sending  a problematic file using DOS FTP (command line).

    Try with the same client application to a different server, which could be on a different OS.

     

    Imported from legacy forums. Posted by André (had 861 views)

    User (Old forums)
    Member
    Post count: 23064

    yes very strange problem

    nothing has changed..everyhing is stabile..version, os, firewall..

    i try chagngin passivemode, nothing happened.

     and i try it on a diferent OS, problem still a problem..

    and when i use dos ftp there is not a problem..i can send it..

     if a file didn’t send, i cant send after a while..every try was unsuccesful..

    when i debug the program, i saw the program was broken when trying to change the transfer status from “sending” to “sent”

    can it be a blocking or something else?

    Imported from legacy forums. Posted by mermaiderya (had 1018 views)

    User (Old forums)
    Member
    Post count: 23064

    and the same program sometimes stop working..

    but there is no transfer no file..

    when i look task manager it is seen working..

    when i close the program and start again it is working..

    can it be the same problem?
     

    Imported from legacy forums. Posted by mermaiderya (had 1163 views)

    User (Old forums)
    Member
    Post count: 23064

    The problem is that is was working before.  So there MUST be something that has changed.

    If you want more help with this, you will need to send an email to support, with a reference to this post, so we can determine your eligibility for support.

    Imported from legacy forums. Posted by André (had 8029 views)

    User (Old forums)
    Member
    Post count: 23064

    We’re currently having the same exact problem in a Windows 2003 server with XCeed FTP Library 1.1 sending to AS400 (only one AS400 server, we’re sending to many).

    Has this problem been nailed out and/or addressed?

     Thanks,

         Mario

     

     

    Imported from legacy forums. Posted by Mario (had 3669 views)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.