Home Forums WinForms controls Xceed Grid for WinForms Allow edit on only one cell in grid Reply To: Allow edit on only one cell in grid

User (Old forums)
Member
Post count: 23064

Your code looks fine, but there could be an exception (e.g. data conversion from the cell to the editor) that is swallowed by the grid, and you don’t see because your debugger is not set to break on all exceptions (Debug Menu -> Exceptions -> Common Language Runtime Exception, then select “Break into the debugger” radio button in VS2003, or select “Thrown” CheckBox in VS2005).

If you are in VS2005, make sure the “Enable Just My Code” CheckBox is unselected (Tools Menu -> Options -> Debugging -> General).

This will make sure that no exceptions are swallowed by the grid, and that the debugger will break in any part of the code, not just yours.

Imported from legacy forums. Posted by André (had 233 views)